CRM service unavailable
Incident Report for Lucidity Cloud Services
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 17:28 NZDT
Monitoring
A fix has been implemented, we are monitoring the service.
Posted Feb 11, 2020 - 15:13 NZDT
Update
Lucidity engineers are still working to resolve this issue, we are sorry for any inconvenience caused.
Posted Feb 11, 2020 - 14:54 NZDT
Identified
Lucidity engineers have identified an issue with CRM and are now working to resolve the issue and restore the service.
Posted Feb 11, 2020 - 13:58 NZDT
This incident affected: Dynamics 365 / CRM.