Lucidity Support Desk - Experiencing delays
Incident Report for Lucidity Cloud Services
Resolved
This incident has been resolved.
Posted Dec 03, 2019 - 08:43 NZDT
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 07:54 NZDT
Investigating
Our support ticket logging system is currently experiencing delays in receiving your requests. For any urgent requests please phone.
Posted Dec 03, 2019 - 07:51 NZDT
This incident affected: Lucidity Support Desk.