Unplanned Outage - Lucidity 365
Incident Report for Lucidity Cloud Services
Resolved
This incident has now been resolved. Lucidity 365 is now available for all customers. If you do experience any issues - please call Lucidity Support Desk.
Posted Jan 20, 2020 - 07:45 NZDT
Update
We are continuing to investigate this issue.
Posted Jan 20, 2020 - 07:29 NZDT
Investigating
We are aware that Lucidity 365 is unavailable. Our engineers are investigating.
Posted Jan 20, 2020 - 06:44 NZDT
This incident affected: Lucidity 365.