Outlook freezing or hanging.
Incident Report for Lucidity Cloud Services
Resolved
Microsoft have resolved this issue.
Posted Feb 03, 2020 - 12:36 NZDT
Monitoring
A fix has been provided by Microsoft and is currently under test. We plan to monitor the fix until 10 January and if there are no issues, roll out the fix to the impacted devices. Note - this is only for Outlook that is connecting to Office 365 Mail.
Posted Jan 07, 2020 - 18:15 NZDT
Investigating
Lucidity have noticed a trend with Microsoft Outlook hanging or not responding with Microsoft Exchange Online services.
This is occurring both inside the Lucidity Managed Desktop and outside on standalone machines.
If you are noticing this issue please call our support desk so that we can provide the extent and feedback to Microsoft.
Posted Dec 21, 2019 - 13:54 NZDT
This incident affected: Office 365.