Back to overview
Degraded

Azure Virtual Desktop services

May 26 at 10:29am NZST
Affected services
Other Services Severity
Microsoft Azure and Office 365 Services

Resolved
Jun 01 at 12:17pm NZST

Good news! The updated version of the Remote Desktop application for Azure Virtual Desktop has been thoroughly tested by both our team and Microsoft, and it brings significant stability improvements.

Based on our testing and collaboration with Microsoft, we have decided to conclude the regular status updates regarding the performance issue. The updated Remote Desktop client ensures a smoother user experience.

However, if you encounter any issues, please contact our support team immediately. We will assist you and gather necessary information to log the issue with Microsoft's support team as we still have an active ticket open with them.

Thank you for your understanding and continued support as we strive to provide an enhanced Azure Virtual Desktop service.

Updated
May 30 at 12:06pm NZST

We have made progress in addressing the service performance issue with Azure Virtual Desktop. By updating the Remote Desktop application to the latest version, we have achieved substantial stability improvements.

Action Required:
To benefit from these enhancements, please follow our provided guide to update your Remote Desktop application promptly.

We have provided a guide on how to update this to all our main contacts that are affected by this issue.

Support and Assistance:
Our dedicated support team is available to assist you throughout the update process.
Contact us via:

Phone: 09 377 2227
Email: support@lucidity.co.nz

Our senior engineers are working with Microsoft to find the root cause of this issue, we will continue to provide updates as we progress this.

Thank you for your continued trust and patience as we work to provide you with the best possible service.

Updated
May 26 at 02:09pm NZST

We want to provide you with an update regarding the ongoing service performance issue.

Our team has taken immediate action and logged a Priority 1 (P1) ticket with Microsoft Support. This ensures that our concern is escalated to the highest level of attention within their organization.

Currently, we are in the process of awaiting a response from Microsoft's support team. We understand the urgency of this matter and are actively engaged with them to expedite the resolution process.

Rest assured that we are committed to working closely with Microsoft to address the issue and restore normal service operations as quickly as possible. We will continue to keep you informed of any updates we receive from their support team.

We sincerely appreciate your patience and understanding during this time. Your satisfaction and the uninterrupted functionality of Azure Virtual Desktop remain our top priorities.

Should you have any questions or require further assistance, please do not hesitate to reach out to our dedicated support team on 09 377 2227 or send an email to support@lucidity.co.nz. We are here to help.

Thank you for your cooperation.

Created
May 26 at 10:29am NZST

We are currently experiencing some issues with the Azure Virtual Desktop services, and our team is working diligently to resolve them. We apologize for any inconvenience caused and appreciate your patience.

Here's what you need to know:

Performance Degradation: Some users may be experiencing performance degradation, such as slower response times or intermittent connectivity. We are also seeing complete disconnects or log offs. Our senior engineers are actively investigating the root cause and implementing necessary measures to restore optimal performance.

Support and Updates: Our support team is closely monitoring the situation and working to provide regular updates. Please stay tuned for further announcements via our status reports.

Resolution Timeline: We understand the urgency of resolving these issues and are committed to resolving them as quickly as possible. Our senior engineers are working around the clock to restore full service functionality. We will provide an estimated timeline for resolution as soon as we have more information.