Service Disruption: Azure and Kaseya Impacted
Resolved
Oct 30 at 04:05pm NZDT
Microsoft Azure has fully mitigated the recent outage caused by an Azure Front Door configuration change. Full recovery was achieved at 23:20 UTC (12:20 PM NZDT), and services are now operational across all regions.
Since then, Microsoft has removed all incidents from the Azure Status Dashboard, indicating global stability and full resolution.
If you require assistance, please contact us via phone or submit a ticket online. For urgent issues, please call us directly.
Thank you for your patience and cooperation during this incident.
Affected services
Updated
Oct 30 at 12:27pm NZDT
Microsoft Azure has completed recovery efforts following the major outage on October 29 caused by an inadvertent configuration change in Azure Front Door, which triggered DNS failures and disrupted access to multiple services globally.
Latest from Microsoft:
Full mitigation was achieved at 23:20 UTC (12:20 PM NZDT). Most regions are now fully operational.
Access to the Azure Portal has been restored, and core services are functioning normally.
Azure Front Door configuration changes remain temporarily restricted until Microsoft confirms full stability.
Recovery was gradual by design to prevent overload, but traffic is now routed through healthy nodes.
From Lucidity:
Our support systems are fully operational, and ticket processing has resumed.
Azure Virtual Desktop (AVD) was not affected and continues to operate normally.
If you require assistance, please contact us via phone or submit a ticket online. For urgent issues, please call us directly.
We appreciate your patience and understanding during this incident. We will continue to provide updates on any residual issues until Microsoft confirms full stability.
Thank you for your cooperation.
Affected services
Updated
Oct 30 at 10:26am NZDT
Microsoft Azure experienced a major outage on October 29 due to an inadvertent configuration change in Azure Front Door, which triggered DNS failures and disrupted access to multiple services globally. This impacted the Azure Portal, Microsoft 365, and other dependent services.
Latest from Microsoft:
Microsoft has rolled back to its last known good configuration and is actively rerouting traffic through healthy nodes.
Customers may now see signs of recovery, but some services remain degraded, and configuration changes are still temporarily blocked.
Access to the Azure Portal has largely been restored, though certain extensions (e.g., Marketplace) may still experience intermittent issues.
From Lucidity:
We can now access tickets as normal, so support operations are resuming. However, some services remain degraded, so response times may still be slower than usual.
Azure Virtual Desktop (AVD) was not affected and continues to operate normally.
If you require assistance, you can now contact us via phone or submit a ticket, as our ticketing system is back online. For urgent issues, please call us directly.
We appreciate your patience and understanding during this recovery period.
Thank you for your cooperation
Affected services
Created
Oct 30 at 09:01am NZDT
We want to inform you that Microsoft Azure is currently experiencing a widespread outage affecting multiple services, including access to the Azure Portal and some Microsoft 365 applications. The issue appears to be related to Azure Front Door and DNS disruptions following a configuration change.
Microsoft has initiated mitigation steps, including rolling back to a previous stable configuration and rerouting traffic through healthy nodes. While some customers may see early signs of recovery, full restoration is expected to take several hours. During this time, you may experience intermittent connectivity issues or degraded performance.
Please note:
Azure Virtual Desktop (AVD) services are not affected and continue to operate normally.
Kaseya services are impacted by this outage, which means there will be delays in processing tickets submitted to our support queue. We are actively monitoring and will address all requests as soon as systems stabilize, you can still contact our support team via our phonelines.
We appreciate your patience and understanding during this time. If you have urgent concerns, please contact our support team via our phonelines.
Thank you for your cooperation.
Affected services