Managed Outlook - potential delays with inbound and outbound emails
Incident Report for Lucidity Cloud Services
Resolved
This incident has been resolved. Customers that were affected have been contacted and confirmed that they are no longer experiencing delays.
Posted Jan 10, 2020 - 12:04 NZDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2020 - 13:12 NZDT
Investigating
Managed Outlook customers may be experiencing delays with inbound and outbound emails.

Lucidity Engineers are currently investigating
Posted Jan 09, 2020 - 11:38 NZDT
This incident affected: Managed Outlook.